Spore ModAPI

Download tools like Sporemaster and get the latest patches.
Caution404
Poster of the New User Apocalypse
Poster of the New User Apocalypse
Posts: 1
Joined: Tue May 05, 2020 2:13 am

Re: Spore ModAPI

Unread post by Caution404 »

Hi there. Im having an issue playing spore. I have it on Origin with GA and i have installed API and Dark Injection was installed through that fine. However when ever i go to run the game through Api i get the following error.

https://hosting.photobucket.com/images/pp106/

i have tried to restart my computer to see if that works as you have mentioned it with a few others. I have only Downloaded the most recent spore and API in the last few days. Any help would be much appreciated, thank you in advance.
Sijeyb
Poster of the New User Apocalypse
Poster of the New User Apocalypse
Posts: 3
Joined: Thu May 07, 2020 12:49 pm

Re: Spore ModAPI

Unread post by Sijeyb »

Ok, this reply might be the late one, I have used the spore modapi installer and even installed dark injections, when i start up the launcher, why do I get the message "If you're using the Steam version of Spore or the GOG version of Spore, please update to version 3.1.0.22 to proceed. If you're already using Origin Spore and you see this message, or if you're already using a higher version of Spore, please inform rob55rod or emd4600 immediately."

Aaaaand the launcher will close. What did it mean 3.1.0.22? If the version of Spore is just on 1.06?

Well, I already have the latest patch, which is the asymmetry patch. Is there anyway to fix it? btw, i'm new so forgive me if i forgot something.
j u s t a new user with horrible problems hecc
Sijeyb
Poster of the New User Apocalypse
Poster of the New User Apocalypse
Posts: 3
Joined: Thu May 07, 2020 12:49 pm

Re: Spore ModAPI

Unread post by Sijeyb »

Sijeyb wrote:Ok, this reply might be the late one, I have used the spore modapi installer and even installed dark injections, when i start up the launcher, why do I get the message "If you're using the Steam version of Spore or the GOG version of Spore, please update to version 3.1.0.22 to proceed. If you're already using Origin Spore and you see this message, or if you're already using a higher version of Spore, please inform rob55rod or emd4600 immediately."

Aaaaand the launcher will close. What did it mean 3.1.0.22? If the version of Spore is just on 1.06?

Well, I already have the latest patch, which is the asymmetry patch. Is there anyway to fix it? btw, i'm new so forgive me if i forgot something.Ok, this reply might be the late one, I have used the spore modapi installer and even installed dark injections, when i start up the launcher, why do I get the message "If you're using the Steam version of Spore or the GOG version of Spore, please update to version 3.1.0.22 to proceed. If you're already using Origin Spore and you see this message, or if you're already using a higher version of Spore, please inform rob55rod or emd4600 immediately."

Aaaaand the launcher will close. What did it mean 3.1.0.22? If the version of Spore is just on 1.06?

Well, I already have the latest patch, which is the asymmetry patch. Is there anyway to fix it? btw, i'm new so forgive me if i forgot something.
Okay, I've read some problems the same as mine, i think the launcher is the problem, where do I get the March 2017 patch? I have patched it 2 times (Auto patch i think) and it does nothing.

Edit: My Spore ModAPI version is 1.2.0.11
Edit 2: My dumbass found my version of spore is 3.0.0.2818 and is there any way to patch it?
j u s t a new user with horrible problems hecc
Sijeyb
Poster of the New User Apocalypse
Poster of the New User Apocalypse
Posts: 3
Joined: Thu May 07, 2020 12:49 pm

Re: Spore ModAPI

Unread post by Sijeyb »

It's seems my spore and the ModAPI launcher have a problem. I have both :ga: and :patch1.5: gog version to be clear. It says that i need the higher version of spore even though i have the patch 5.1 of my spore? I do have :cc: and :ex: and the mod i was trying to test is :di: any help?
j u s t a new user with horrible problems hecc
Septimon
Poster of the New User Apocalypse
Poster of the New User Apocalypse
Posts: 4
Joined: Tue May 12, 2020 4:42 pm

Re: Spore ModAPI

Unread post by Septimon »

GOG Galaxy isn't registering my playtime when using this. Is there a way of changing that?

Thanks!
User avatar
rob55rod
Tech Support
Tech Support
Posts: 4069
Joined: Sat Jul 02, 2011 9:50 am
Gender:

Re: Spore ModAPI

Unread post by rob55rod »

Sijeyb wrote:It's seems my spore and the ModAPI launcher have a problem. I have both :ga: and :patch1.5: gog version to be clear. It says that i need the higher version of spore even though i have the patch 5.1 of my spore? I do have :cc: and :ex: and the mod i was trying to test is :di: any help?
Yeah, you need the March 2017 patch.

Septimon wrote:GOG Galaxy isn't registering my playtime when using this. Is there a way of changing that?

Thanks!
Hmm...not that I'm aware of, sorry. I fear it may just be an inherent limitation of GOG Galaxy's method of tracking what games are running when...
Having trouble with the Spore ModAPI Launcher Kit? Get help here!

If you're reading this, you have my permission to build off of my mods as long as I am credited. Please don't mirror my work unaltered, unless I no longer provide a working download.
Septimon
Poster of the New User Apocalypse
Poster of the New User Apocalypse
Posts: 4
Joined: Tue May 12, 2020 4:42 pm

Re: Spore ModAPI

Unread post by Septimon »

rob55rod wrote:Hmm...not that I'm aware of, sorry. I fear it may just be an inherent limitation of GOG Galaxy's method of tracking what games are running when...
Ah, ok! I shall hope GOG Galaxy patches it then :)
ShadowSky101
Poster of the New User Apocalypse
Poster of the New User Apocalypse
Posts: 2
Joined: Sun Dec 23, 2018 3:15 pm

Re: Spore ModAPI

Unread post by ShadowSky101 »

Hiya! I'd gotten a new better laptop, and the api used to work just fine on my last one but when ever the launcher tries launching apparently access get's denied somewhere along the lines of the files. I'd suspected it was probably my malware/antivirus protection but it hasn't reported anything that matches the time. On the additional error info, it says errorcode: -2147467256, Nativeerrorcode: 5, and HResult: -2147467256. If that helps at all. I also have the first error message with more details if needed.

For other extras, I am using the steam installed spore and all.
User avatar
rob55rod
Tech Support
Tech Support
Posts: 4069
Joined: Sat Jul 02, 2011 9:50 am
Gender:

Re: Spore ModAPI

Unread post by rob55rod »

Septimon wrote:
rob55rod wrote:Hmm...not that I'm aware of, sorry. I fear it may just be an inherent limitation of GOG Galaxy's method of tracking what games are running when...
Ah, ok! I shall hope GOG Galaxy patches it then :)
That would be nice...though I can't imagine how they could do so in any practical manner...
ShadowSky101 wrote:Hiya! I'd gotten a new better laptop, and the api used to work just fine on my last one but when ever the launcher tries launching apparently access get's denied somewhere along the lines of the files. I'd suspected it was probably my malware/antivirus protection but it hasn't reported anything that matches the time. On the additional error info, it says errorcode: -2147467256, Nativeerrorcode: 5, and HResult: -2147467256. If that helps at all. I also have the first error message with more details if needed.

For other extras, I am using the steam installed spore and all.
That sounds like a Steam Spore-related problem, unfortunately...consider it dumb luck that the Spore ModAPI Launcher Kit even worked with Steam Spore on your old computer. Fortunately, it's usually possible to transfer your Steam license keys for Spore and its DLCs to Origin, allowing you to obtain that version of the game. Just make sure that you backup your creations and save data and uninstall Steam Spore before you install Origin Spore! (I can help you with that, if needed. Just let me know.)
Having trouble with the Spore ModAPI Launcher Kit? Get help here!

If you're reading this, you have my permission to build off of my mods as long as I am credited. Please don't mirror my work unaltered, unless I no longer provide a working download.
ShadowSky101
Poster of the New User Apocalypse
Poster of the New User Apocalypse
Posts: 2
Joined: Sun Dec 23, 2018 3:15 pm

Re: Spore ModAPI

Unread post by ShadowSky101 »

rob55rod wrote:
Septimon wrote:
rob55rod wrote:Hmm...not that I'm aware of, sorry. I fear it may just be an inherent limitation of GOG Galaxy's method of tracking what games are running when...
Ah, ok! I shall hope GOG Galaxy patches it then :)
That would be nice...though I can't imagine how they could do so in any practical manner...
ShadowSky101 wrote:Hiya! I'd gotten a new better laptop, and the api used to work just fine on my last one but when ever the launcher tries launching apparently access get's denied somewhere along the lines of the files. I'd suspected it was probably my malware/antivirus protection but it hasn't reported anything that matches the time. On the additional error info, it says errorcode: -2147467256, Nativeerrorcode: 5, and HResult: -2147467256. If that helps at all. I also have the first error message with more details if needed.

For other extras, I am using the steam installed spore and all.
That sounds like a Steam Spore-related problem, unfortunately...consider it dumb luck that the Spore ModAPI Launcher Kit even worked with Steam Spore on your old computer. Fortunately, it's usually possible to transfer your Steam license keys for Spore and its DLCs to Origin, allowing you to obtain that version of the game. Just make sure that you backup your creations and save data and uninstall Steam Spore before you install Origin Spore! (I can help you with that, if needed. Just let me know.)
Ah alrighty then! Thank you!
greenwiz34
Poster of the New User Apocalypse
Poster of the New User Apocalypse
Posts: 1
Joined: Sat May 23, 2020 10:25 pm

Re: Spore ModAPI

Unread post by greenwiz34 »

Hey, I don't know if this has already been addressed in this forum, but in case anyone else comes digging for answers, here's my two bits.

It seems ModAPI doesn't like being run as administrator. It kept throwing Error Code 2 messages at me, and it took me all day to figure out why.

I had launched GA right after installing it through Origin, got a compatibility message from Windows 10, clicked OK (or Yes, I don't recall exactly what it said) to run in compatibility mode, and GA worked fine.

Then I installed ModAPI and DI, following all the instructions I could find, including not running the ModAPI Launcher as administrator, only to get the aforementioned ErrorCode 2 message.

I tried restarting my computer and reinstalling everything related to Spore (in stages), to no avail. Then I looked at the properties>compatibility tab for each version of SporeApp.exe (don't ask what inspired me to look there), and noticed the box for "run as administrator" was checked. I cleared those, and VOILA! ModAPI now launches GA + DI, no problem.

I think this is the first time I've seen "Run as Administrator" cause an error for a program...

Hopefully my experience will save someone else a full day of troubleshooting!
User avatar
draker585
Poster of the New User Apocalypse
Poster of the New User Apocalypse
Posts: 1
Joined: Sun Dec 29, 2019 2:51 pm

Re: Spore ModAPI

Unread post by draker585 »

When i attempt to update the launcher, the updater either doesn't launch, or opens to pure black and hangs up, leaving it just causes it to close, and when i open the launcher again it says that a new update is available.
*aggressively whips and nae naes*
User avatar
Herbios
Recruit
Recruit
Posts: 9
Joined: Fri May 29, 2020 4:53 am

Re: Spore ModAPI

Unread post by Herbios »

rob55rod wrote:
Sijeyb wrote:It's seems my spore and the ModAPI launcher have a problem. I have both :ga: and :patch1.5: gog version to be clear. It says that i need the higher version of spore even though i have the patch 5.1 of my spore? I do have :cc: and :ex: and the mod i was trying to test is :di: any help?
Yeah, you need the March 2017 patch.

Septimon wrote:GOG Galaxy isn't registering my playtime when using this. Is there a way of changing that?

Thanks!
Hmm...not that I'm aware of, sorry. I fear it may just be an inherent limitation of GOG Galaxy's method of tracking what games are running when...
where can i get the march 2017 patch? i thought i had it but since it doesn't work anymore saying reopen it through the sporeModAPI launcher, even tho i am opening from the luncher? how can i fix it?
Attachments
ss.png
User avatar
rob55rod
Tech Support
Tech Support
Posts: 4069
Joined: Sat Jul 02, 2011 9:50 am
Gender:

Re: Spore ModAPI

Unread post by rob55rod »

Herbios wrote:where can i get the march 2017 patch? i thought i had it but since it doesn't work anymore saying reopen it through the sporeModAPI launcher, even tho i am opening from the luncher? how can i fix it?
If you bought Spore from Origin or GOG, you should be able to obtain the March 2017 patch by simply uninstalling and reinstalling the game and your mods. Just be sure to back up your creations and save data before doing so.
Having trouble with the Spore ModAPI Launcher Kit? Get help here!

If you're reading this, you have my permission to build off of my mods as long as I am credited. Please don't mirror my work unaltered, unless I no longer provide a working download.
User avatar
Herbios
Recruit
Recruit
Posts: 9
Joined: Fri May 29, 2020 4:53 am

Re: Spore ModAPI

Unread post by Herbios »

rob55rod wrote:
Herbios wrote:where can i get the march 2017 patch? i thought i had it but since it doesn't work anymore saying reopen it through the sporeModAPI launcher, even tho i am opening from the luncher? how can i fix it?
If you bought Spore from Origin or GOG, you should be able to obtain the March 2017 patch by simply uninstalling and reinstalling the game and your mods. Just be sure to back up your creations and save data before doing so.
Well you've helped me in discord so thanks for fixing the ModAPI problems, i can't thank enough
rolpo2
Recruit
Recruit
Posts: 7
Joined: Sat May 30, 2020 9:08 am

Re: Spore ModAPI

Unread post by rolpo2 »

It successfully opens spore ga but nothing is changed? i look at the data EP1 files and all of the mod's data is there. any help?
User avatar
Herbios
Recruit
Recruit
Posts: 9
Joined: Fri May 29, 2020 4:53 am

Re: Spore ModAPI

Unread post by Herbios »

rolpo2 wrote:It successfully opens spore ga but nothing is changed? i look at the data EP1 files and all of the mod's data is there. any help?
Did you test the parts and etc?
kittylord64
Poster of the New User Apocalypse
Poster of the New User Apocalypse
Posts: 1
Joined: Sun May 31, 2020 8:04 am

Re: Spore ModAPI

Unread post by kittylord64 »

its telling me to update to v 3.1.0.22 btw im useing gog
also how do i update
IceWallowEggs
Poster of the New User Apocalypse
Poster of the New User Apocalypse
Posts: 1
Joined: Thu Jun 11, 2020 11:13 pm

Re: Spore ModAPI

Unread post by IceWallowEggs »

I cannot open anything, i have infinite colours and thats all, im on steam because origin is straight garbage
Attachments
vvvc.PNG
Soviet Opossum
Poster of the New User Apocalypse
Poster of the New User Apocalypse
Posts: 1
Joined: Sun Jun 14, 2020 1:53 pm

Re: Spore ModAPI

Unread post by Soviet Opossum »

I tried starting up with the launcher but it keeps giving me an error.
Post Reply

Return to “Tools & Patches”