Spore crashes after Installing Dark Injections

Forum rules
BEFORE YOU POST...

Remember that mods you download that are created by Davo REQUIRE Spore: Galactic Adventures and REQUIRE your game to be installed & patched in this order.

    - Install Spore Game

    - (OPTIONAL) Install Spore C&C

    - Install Spore Galactic Adventures

    - Patch Spore and Spore Galactic Adventures to 1.5.1

If you have any further questions, feel free to ask.
User avatar
MewtwoFanz
Private
Private
Posts: 25
Joined: Mon Jan 04, 2016 1:19 pm

Spore crashes after Installing Dark Injections

Unread postby MewtwoFanz » Fri Aug 30, 2019 3:37 pm

Hi, I am having a HUGE problem with Dark Injections. After installing it, when I launch it through ModAPI Launcher, It crashes! it doesn't give me any error messages, either. Can someone help me?
:di:
"Watashi wa Dare da?"
~Mewtwo, from
Mewtwo's Counterattack (Mewtwo Stikes Back, Japanese Ver.)

My Spore Username is: MewtwoAmberLove1

User avatar
rob55rod
Tech Support
Tech Support
Sergeant Major of the Davo Army
Sergeant Major of the Davo Army
Posts: 3877
Joined: Sat Jul 02, 2011 9:50 am
Location: Zelem's Nexus, rebuilding.

Re: Spore crashes after Installing Dark Injections

Unread postby rob55rod » Sat Aug 31, 2019 12:51 pm

Try running the Spore ModAPI Launcher with these commandline options:

Code: Select all

-w -r:1024x768
Having trouble with the Spore ModAPI Launcher Kit? Let us know here!

If you're reading this, you have my permission to build off of my mods as long as I am credited. Please don't mirror my work unaltered, unless I no longer provide a working download.

User avatar
MewtwoFanz
Private
Private
Posts: 25
Joined: Mon Jan 04, 2016 1:19 pm

Re: Spore crashes after Installing Dark Injections

Unread postby MewtwoFanz » Mon Sep 02, 2019 2:11 pm

rob55rod wrote:Try running the Spore ModAPI Launcher with these commandline options:

Code: Select all

-w -r:1024x768

I can try that, but how do I add the commandline options though? sorry i'm not the best at these things
:di:
"Watashi wa Dare da?"
~Mewtwo, from
Mewtwo's Counterattack (Mewtwo Stikes Back, Japanese Ver.)

My Spore Username is: MewtwoAmberLove1

User avatar
rob55rod
Tech Support
Tech Support
Sergeant Major of the Davo Army
Sergeant Major of the Davo Army
Posts: 3877
Joined: Sat Jul 02, 2011 9:50 am
Location: Zelem's Nexus, rebuilding.

Re: Spore crashes after Installing Dark Injections

Unread postby rob55rod » Wed Sep 04, 2019 6:32 am

MewtwoFanz wrote:
rob55rod wrote:Try running the Spore ModAPI Launcher with these commandline options:

Code: Select all

-w -r:1024x768

I can try that, but how do I add the commandline options though? sorry i'm not the best at these things

Open the Spore ModAPI Launcher batch script on your desktop in Notepad or some other text editor that isn't a word processor, go to the very end of the file, add a space, followed by the commandline options I gave you. Save, close, and run the batch script. Let me know if anything changes.
Having trouble with the Spore ModAPI Launcher Kit? Let us know here!

If you're reading this, you have my permission to build off of my mods as long as I am credited. Please don't mirror my work unaltered, unless I no longer provide a working download.

User avatar
MewtwoFanz
Private
Private
Posts: 25
Joined: Mon Jan 04, 2016 1:19 pm

Re: Spore crashes after Installing Dark Injections

Unread postby MewtwoFanz » Sat Sep 14, 2019 2:43 pm

rob55rod wrote:
MewtwoFanz wrote:
rob55rod wrote:Try running the Spore ModAPI Launcher with these commandline options:

Code: Select all

-w -r:1024x768

I can try that, but how do I add the commandline options though? sorry i'm not the best at these things

Open the Spore ModAPI Launcher batch script on your desktop in Notepad or some other text editor that isn't a word processor, go to the very end of the file, add a space, followed by the commandline options I gave you. Save, close, and run the batch script. Let me know if anything changes.


Hey, so I tried to find the batch script, but I realized it wasn't there. what kind of file was it? because I couldn't find it. the only batch scripts I found were the ones for the installer & uninstaller.
:di:
"Watashi wa Dare da?"
~Mewtwo, from
Mewtwo's Counterattack (Mewtwo Stikes Back, Japanese Ver.)

My Spore Username is: MewtwoAmberLove1

User avatar
rob55rod
Tech Support
Tech Support
Sergeant Major of the Davo Army
Sergeant Major of the Davo Army
Posts: 3877
Joined: Sat Jul 02, 2011 9:50 am
Location: Zelem's Nexus, rebuilding.

Re: Spore crashes after Installing Dark Injections

Unread postby rob55rod » Sun Sep 15, 2019 8:40 am

MewtwoFanz wrote:Hey, so I tried to find the batch script, but I realized it wasn't there. what kind of file was it? because I couldn't find it. the only batch scripts I found were the ones for the installer & uninstaller.
Then someone or something must have removed it...

If you know where you installed the Spore ModAPI Launcher Kit to, you can use a desktop shortcut to the Spore ModAPI Launcher instead.
Having trouble with the Spore ModAPI Launcher Kit? Let us know here!

If you're reading this, you have my permission to build off of my mods as long as I am credited. Please don't mirror my work unaltered, unless I no longer provide a working download.

User avatar
MewtwoFanz
Private
Private
Posts: 25
Joined: Mon Jan 04, 2016 1:19 pm

Re: Spore crashes after Installing Dark Injections

Unread postby MewtwoFanz » Thu Sep 19, 2019 3:07 pm

rob55rod wrote:
MewtwoFanz wrote:Hey, so I tried to find the batch script, but I realized it wasn't there. what kind of file was it? because I couldn't find it. the only batch scripts I found were the ones for the installer & uninstaller.
Then someone or something must have removed it...

If you know where you installed the Spore ModAPI Launcher Kit to, you can use a desktop shortcut to the Spore ModAPI Launcher instead.


Hey, I tried reinstalling ModAPI to my existing location, and I think I might have the scripts again. But could you tell me which file i'm supposed to change?
:di:
"Watashi wa Dare da?"
~Mewtwo, from
Mewtwo's Counterattack (Mewtwo Stikes Back, Japanese Ver.)

My Spore Username is: MewtwoAmberLove1

User avatar
rob55rod
Tech Support
Tech Support
Sergeant Major of the Davo Army
Sergeant Major of the Davo Army
Posts: 3877
Joined: Sat Jul 02, 2011 9:50 am
Location: Zelem's Nexus, rebuilding.

Re: Spore crashes after Installing Dark Injections

Unread postby rob55rod » Sat Sep 21, 2019 4:30 pm

MewtwoFanz wrote:Hey, I tried reinstalling ModAPI to my existing location, and I think I might have the scripts again. But could you tell me which file i'm supposed to change?

"Spore ModAPI Launcher.bat"
Having trouble with the Spore ModAPI Launcher Kit? Let us know here!

If you're reading this, you have my permission to build off of my mods as long as I am credited. Please don't mirror my work unaltered, unless I no longer provide a working download.

User avatar
MewtwoFanz
Private
Private
Posts: 25
Joined: Mon Jan 04, 2016 1:19 pm

Re: Spore crashes after Installing Dark Injections

Unread postby MewtwoFanz » Sat Sep 21, 2019 5:03 pm

rob55rod wrote:
MewtwoFanz wrote:Hey, I tried reinstalling ModAPI to my existing location, and I think I might have the scripts again. But could you tell me which file i'm supposed to change?

"Spore ModAPI Launcher.bat"


OK, now that I'm looking at my folder, I've just realized I don't have ANY .bat files! None for the launcher, nor the installer or uninstaller. I don't know if I should be asking this, but is there a way I could download those files? Because I don't know what else to do.

I'm sorry I've caused so much trouble for this
:di:
"Watashi wa Dare da?"
~Mewtwo, from
Mewtwo's Counterattack (Mewtwo Stikes Back, Japanese Ver.)

My Spore Username is: MewtwoAmberLove1

User avatar
rob55rod
Tech Support
Tech Support
Sergeant Major of the Davo Army
Sergeant Major of the Davo Army
Posts: 3877
Joined: Sat Jul 02, 2011 9:50 am
Location: Zelem's Nexus, rebuilding.

Re: Spore crashes after Installing Dark Injections

Unread postby rob55rod » Sat Sep 21, 2019 5:19 pm

MewtwoFanz wrote:
rob55rod wrote:
MewtwoFanz wrote:Hey, I tried reinstalling ModAPI to my existing location, and I think I might have the scripts again. But could you tell me which file i'm supposed to change?

"Spore ModAPI Launcher.bat"


OK, now that I'm looking at my folder, I've just realized I don't have ANY .bat files! None for the launcher, nor the installer or uninstaller. I don't know if I should be asking this, but is there a way I could download those files? Because I don't know what else to do.

...wait, what? What folder? The batch scripts should be on your desktop...

MewtwoFanz wrote:I'm sorry I've caused so much trouble for this
Do not apologize. You've done nothing wrong. Do you really think I'd have an entire subforum dedicated to finding and fixing problems if I didn't want people to help me do so?
Having trouble with the Spore ModAPI Launcher Kit? Let us know here!

If you're reading this, you have my permission to build off of my mods as long as I am credited. Please don't mirror my work unaltered, unless I no longer provide a working download.

User avatar
MewtwoFanz
Private
Private
Posts: 25
Joined: Mon Jan 04, 2016 1:19 pm

Re: Spore crashes after Installing Dark Injections

Unread postby MewtwoFanz » Sat Sep 21, 2019 5:34 pm

rob55rod wrote:
MewtwoFanz wrote:
rob55rod wrote:"Spore ModAPI Launcher.bat"


OK, now that I'm looking at my folder, I've just realized I don't have ANY .bat files! None for the launcher, nor the installer or uninstaller. I don't know if I should be asking this, but is there a way I could download those files? Because I don't know what else to do.

...wait, what? What folder? The batch scripts should be on your desktop...

MewtwoFanz wrote:I'm sorry I've caused so much trouble for this
Do not apologize. You've done nothing wrong. Do you really think I'd have an entire subforum dedicated to finding and fixing problems if I didn't want people to help me do so?


I'm talking about the folder in which I installed ModAPI. Shouldn't it be in there? I thought it would be.

Oh btw, thank you for trying to help me so far. I just have a lot of self esteem and anxiety issues, so I feel like I should be sorry for things I didn't do or say because nobody will accept me if I'm not. (That's how my mom taught me things....)
:di:
"Watashi wa Dare da?"
~Mewtwo, from
Mewtwo's Counterattack (Mewtwo Stikes Back, Japanese Ver.)

My Spore Username is: MewtwoAmberLove1

User avatar
rob55rod
Tech Support
Tech Support
Sergeant Major of the Davo Army
Sergeant Major of the Davo Army
Posts: 3877
Joined: Sat Jul 02, 2011 9:50 am
Location: Zelem's Nexus, rebuilding.

Re: Spore crashes after Installing Dark Injections

Unread postby rob55rod » Sun Sep 22, 2019 10:37 am

MewtwoFanz wrote:I'm talking about the folder in which I installed ModAPI. Shouldn't it be in there? I thought it would be.
Okay...allow me to clarify this situation: The entire reason for these batch scripts' existence is to allow the user to access the Spore ModAPI Launcher Kit from a known location - the desktop - without having to know or care where the kit is actually installed to on their hard drive. I wanted to use desktop shortcuts, but ran into some trouble with programmatically creating those, and so used batch scripts instead for the time being.

All that said, if you've already located the installation folder for the Spore ModAPI Launcher Kit, then you may as well just create a desktop shortcut to the Spore ModAPI Launcher itself (right-click --> "Send to..." --> "Desktop (create shortcut)"). It will be easier to make the necessary changes to that than to the batch scripts - once you've created the shortcut on your desktop, just right-click it, go to Properties, then to the Shortcut tab, and then add the commandline options I gave you earlier to the very end of the "Target" field. If you want to double-check you've filled the field out correctly, feel free to post a screenshot, and I'll take a look.


MewtwoFanz wrote:Oh btw, thank you for trying to help me so far.
No problem, I'm always happy to help whenever I'm able to do so.


MewtwoFanz wrote:I just have a lot of self esteem and anxiety issues, so I feel like I should be sorry for things I didn't do or say because nobody will accept me if I'm not.
You're not alone in that. To some extent, I can relate, especially irl...albeit perhaps for different reasons.

If it's any reassurance, you have no reason to apologize for anything that has taken place here. If anything, I'm grateful that you brought the issue to my attention instead of just...uninstalling DI and moving on, as some people would - by doing so, you've given me an opportunity to identify the cause and a solution to the problem. This means that not only will you hopefully be able to play with DI once we're done, but the outcome of this will also be helpful to me in the future, should anyone else encounter the same problem, provided we're able to locate a working solution. So, weird as this may sound...thank you. Thank you for taking the time to report this issue and help me diagnose it.


MewtwoFanz wrote:(That's how my mom taught me things....)
...huh.
Having trouble with the Spore ModAPI Launcher Kit? Let us know here!

If you're reading this, you have my permission to build off of my mods as long as I am credited. Please don't mirror my work unaltered, unless I no longer provide a working download.

User avatar
MewtwoFanz
Private
Private
Posts: 25
Joined: Mon Jan 04, 2016 1:19 pm

Re: Spore crashes after Installing Dark Injections

Unread postby MewtwoFanz » Mon Sep 23, 2019 12:59 pm

rob55rod wrote:
MewtwoFanz wrote:I'm talking about the folder in which I installed ModAPI. Shouldn't it be in there? I thought it would be.
Okay...allow me to clarify this situation: The entire reason for these batch scripts' existence is to allow the user to access the Spore ModAPI Launcher Kit from a known location - the desktop - without having to know or care where the kit is actually installed to on their hard drive. I wanted to use desktop shortcuts, but ran into some trouble with programmatically creating those, and so used batch scripts instead for the time being.

All that said, if you've already located the installation folder for the Spore ModAPI Launcher Kit, then you may as well just create a desktop shortcut to the Spore ModAPI Launcher itself (right-click --> "Send to..." --> "Desktop (create shortcut)"). It will be easier to make the necessary changes to that than to the batch scripts - once you've created the shortcut on your desktop, just right-click it, go to Properties, then to the Shortcut tab, and then add the commandline options I gave you earlier to the very end of the "Target" field. If you want to double-check you've filled the field out correctly, feel free to post a screenshot, and I'll take a look.


MewtwoFanz wrote:Oh btw, thank you for trying to help me so far.
No problem, I'm always happy to help whenever I'm able to do so.


MewtwoFanz wrote:I just have a lot of self esteem and anxiety issues, so I feel like I should be sorry for things I didn't do or say because nobody will accept me if I'm not.
You're not alone in that. To some extent, I can relate, especially irl...albeit perhaps for different reasons.

If it's any reassurance, you have no reason to apologize for anything that has taken place here. If anything, I'm grateful that you brought the issue to my attention instead of just...uninstalling DI and moving on, as some people would - by doing so, you've given me an opportunity to identify the cause and a solution to the problem. This means that not only will you hopefully be able to play with DI once we're done, but the outcome of this will also be helpful to me in the future, should anyone else encounter the same problem, provided we're able to locate a working solution. So, weird as this may sound...thank you. Thank you for taking the time to report this issue and help me diagnose it.


MewtwoFanz wrote:(That's how my mom taught me things....)
...huh.


Hey, so I tried the command input you gave me originally (thanks for helping me figure that out), but it still didn't work. Pretty much the same exact result. Any other suggestions?
:di:
"Watashi wa Dare da?"
~Mewtwo, from
Mewtwo's Counterattack (Mewtwo Stikes Back, Japanese Ver.)

My Spore Username is: MewtwoAmberLove1

User avatar
rob55rod
Tech Support
Tech Support
Sergeant Major of the Davo Army
Sergeant Major of the Davo Army
Posts: 3877
Joined: Sat Jul 02, 2011 9:50 am
Location: Zelem's Nexus, rebuilding.

Re: Spore crashes after Installing Dark Injections

Unread postby rob55rod » Tue Sep 24, 2019 7:55 am

MewtwoFanz wrote:Hey, so I tried the command input you gave me originally (thanks for helping me figure that out), but it still didn't work. Pretty much the same exact result. Any other suggestions?

Well that's...odd.

Okay, here's a dumb idea that has worked before for no apparent reason...completely uninstall DI (use the Spore ModAPI Easy Uninstaller to do so), then download a new copy of DI and install that. Let me know whether or not that changes anything.
Having trouble with the Spore ModAPI Launcher Kit? Let us know here!

If you're reading this, you have my permission to build off of my mods as long as I am credited. Please don't mirror my work unaltered, unless I no longer provide a working download.

User avatar
MewtwoFanz
Private
Private
Posts: 25
Joined: Mon Jan 04, 2016 1:19 pm

Re: Spore crashes after Installing Dark Injections

Unread postby MewtwoFanz » Wed Sep 25, 2019 12:35 pm

rob55rod wrote:
MewtwoFanz wrote:Hey, so I tried the command input you gave me originally (thanks for helping me figure that out), but it still didn't work. Pretty much the same exact result. Any other suggestions?

Well that's...odd.

Okay, here's a dumb idea that has worked before for no apparent reason...completely uninstall DI (use the Spore ModAPI Easy Uninstaller to do so), then download a new copy of DI and install that. Let me know whether or not that changes anything.


I tried it, and it didn't work. Any other options?
Also, just a side note, I had been playing dark injections for a while now, until I had this problem.
:di:
"Watashi wa Dare da?"
~Mewtwo, from
Mewtwo's Counterattack (Mewtwo Stikes Back, Japanese Ver.)

My Spore Username is: MewtwoAmberLove1

User avatar
rob55rod
Tech Support
Tech Support
Sergeant Major of the Davo Army
Sergeant Major of the Davo Army
Posts: 3877
Joined: Sat Jul 02, 2011 9:50 am
Location: Zelem's Nexus, rebuilding.

Re: Spore crashes after Installing Dark Injections

Unread postby rob55rod » Wed Sep 25, 2019 4:00 pm

MewtwoFanz wrote:I tried it, and it didn't work. Any other options?
Also, just a side note, I had been playing dark injections for a while now, until I had this problem.

Odd...do you have any other mods installed?
Having trouble with the Spore ModAPI Launcher Kit? Let us know here!

If you're reading this, you have my permission to build off of my mods as long as I am credited. Please don't mirror my work unaltered, unless I no longer provide a working download.

User avatar
MewtwoFanz
Private
Private
Posts: 25
Joined: Mon Jan 04, 2016 1:19 pm

Re: Spore crashes after Installing Dark Injections

Unread postby MewtwoFanz » Sun Oct 20, 2019 4:40 pm

rob55rod wrote:
MewtwoFanz wrote:I tried it, and it didn't work. Any other options?
Also, just a side note, I had been playing dark injections for a while now, until I had this problem.

Odd...do you have any other mods installed?


Yes, I do, but too many to list, so i'll list the major ones I used along with dark injections:

2015 Seamless limbtails
2017 camben color pack
infinite scaling
pandora's toolbox
enhanced color picker
subtle rotations
universal property replacement v0.2.1
no grox 2017 update
!!!!!!!!!!!!!2017PATCHTEST2__Adventure_ExtraSize-InfiniteComplexity-100points
2018 film bg
editor bg

These are just a few of the mods I use. if you need a full list, I can send you the files from my computer. I hope this helps! (BTW Sorry for the late response)
:di:
"Watashi wa Dare da?"
~Mewtwo, from
Mewtwo's Counterattack (Mewtwo Stikes Back, Japanese Ver.)

My Spore Username is: MewtwoAmberLove1

User avatar
rob55rod
Tech Support
Tech Support
Sergeant Major of the Davo Army
Sergeant Major of the Davo Army
Posts: 3877
Joined: Sat Jul 02, 2011 9:50 am
Location: Zelem's Nexus, rebuilding.

Re: Spore crashes after Installing Dark Injections

Unread postby rob55rod » Wed Oct 23, 2019 7:10 am

MewtwoFanz wrote:These are just a few of the mods I use. if you need a full list, I can send you the files from my computer. I hope this helps!

I'll need a comprehensive list, yes.

MewtwoFanz wrote:(BTW Sorry for the late response)

np
Having trouble with the Spore ModAPI Launcher Kit? Let us know here!

If you're reading this, you have my permission to build off of my mods as long as I am credited. Please don't mirror my work unaltered, unless I no longer provide a working download.

User avatar
MewtwoFanz
Private
Private
Posts: 25
Joined: Mon Jan 04, 2016 1:19 pm

Re: Spore crashes after Installing Dark Injections

Unread postby MewtwoFanz » Sun Oct 27, 2019 12:08 pm

rob55rod wrote:
MewtwoFanz wrote:These are just a few of the mods I use. if you need a full list, I can send you the files from my computer. I hope this helps!

I'll need a comprehensive list, yes.

MewtwoFanz wrote:(BTW Sorry for the late response)

np


https://photos.app.goo.gl/D5tL5NWc9R49J1QY8
https://photos.app.goo.gl/2hdPi5stVvzq5fk97
https://photos.app.goo.gl/5jpLKj3KXGm9zdES7
https://photos.app.goo.gl/Mc9xYajm3nrUcjG79

Here's a list of my currently installed mods. I hilighted the ones that are not DI or spore galactic adventures' regular files. Hope this helps
:di:
"Watashi wa Dare da?"
~Mewtwo, from
Mewtwo's Counterattack (Mewtwo Stikes Back, Japanese Ver.)

My Spore Username is: MewtwoAmberLove1

User avatar
MewtwoFanz
Private
Private
Posts: 25
Joined: Mon Jan 04, 2016 1:19 pm

Re: Spore crashes after Installing Dark Injections

Unread postby MewtwoFanz » Sun Oct 27, 2019 12:39 pm

Hey, guess what I just found out! It has NOTHING to do with Dark Injections, it's the Modapi Launcher! I don't remember who created the modapi launcher, though. So, after doing some looking around on my laptop's files, I think I have more than one ModAPI Launchers installed. How do I fix this, and could somebody make a version of the ModAPI Launcher that can fix this problem and let spore run correctly?
:di:
"Watashi wa Dare da?"
~Mewtwo, from
Mewtwo's Counterattack (Mewtwo Stikes Back, Japanese Ver.)

My Spore Username is: MewtwoAmberLove1


Return to “Help”