Crashes when opening creature creator

Squashed beyond recognition. Unlike real bugs, these weren't alive enough to be worth sparing.
User avatar
scrgp9512
Recruit
Recruit
Posts: 5
Joined: Tue Jan 01, 2019 12:05 am

Crashes when opening creature creator

Unread postby scrgp9512 » Tue Jan 01, 2019 12:09 am

So I'm using Dark Injections for the first time here. I installed it and booted the API launcher and the game launches just fine. However when I go to open the creature creator it never opens, the game crashes and closes before it can do so. I couldn't really find anything here about this already so here's this post. I am using the Steam version and I have GA and C&C with the asymmetry patch.

User avatar
Marduk
Private
Private
Posts: 27
Joined: Sun Dec 23, 2018 4:22 pm
Location: Madrid, Spain
Contact:

Re: Crashes when opening creature creator

Unread postby Marduk » Tue Jan 01, 2019 12:13 pm

scrgp9512 wrote:So I'm using Dark Injections for the first time here. I installed it and booted the API launcher and the game launches just fine. However when I go to open the creature creator it never opens, the game crashes and closes before it can do so. I couldn't really find anything here about this already so here's this post. I am using the Steam version and I have GA and C&C with the asymmetry patch.


Some mods doesn't works with steam version, btw, there's a way to change steam version to origin version, i dunno how, but there was a video on Youtube, i'll try to find it and by the way, what's the installation path? where u installed the mod?
Spore Modder and Member of Annunaki Race.

Also, Pls view my Youtube Channel: https://www.youtube.com/channel/UC7ZEvu ... ObnL-fabCw?

User avatar
VanillaCold
Staff Sergeant
Staff Sergeant
Posts: 199
Joined: Fri Nov 02, 2018 2:36 pm
Contact:

Re: Crashes when opening creature creator

Unread postby VanillaCold » Tue Jan 01, 2019 2:20 pm

Marduk wrote:Some mods doesn't works with steam version, btw, there's a way to change steam version to origin version, i dunno how, but there was a video on Youtube, i'll try to find it and by the way, what's the installation path? where u installed the mod?

All mods which were made for Patch 1.7 work with the Steam version.
Patch 1.7 turns the Origin version into the Steam version, which is why older mods don't work with the latest version.
DI works fine for me, even though I'm using the Steam version.

Anyway, you should try these first:
1: Verify your game files. This will make Steam check for errors within Spore's files. If it finds any corrupt/missing files, it'll redownload them. (this doesn't apply to mods)
2: Uninstall all mods excluding DI and slowly add them back to Spore until you find what's causing the problem.
Creator of Solar Spore, Adventure Water and Spaceplanes.

My main account broke a while ago, so I created this alt.

User avatar
rob55rod
Tech Support
Tech Support
Sergeant Major of the Davo Army
Sergeant Major of the Davo Army
Posts: 3877
Joined: Sat Jul 02, 2011 9:50 am
Location: Zelem's Nexus, rebuilding.

Re: Crashes when opening creature creator

Unread postby rob55rod » Tue Jan 01, 2019 7:54 pm

scrgp9512 wrote:So I'm using Dark Injections for the first time here. I installed it and booted the API launcher and the game launches just fine. However when I go to open the creature creator it never opens, the game crashes and closes before it can do so. I couldn't really find anything here about this already so here's this post. I am using the Steam version and I have GA and C&C with the asymmetry patch.

Hmmm...mind showing me your current DI configuration? (sorry about the confusion above btw)
Having trouble with the Spore ModAPI Launcher Kit? Let us know here!

If you're reading this, you have my permission to build off of my mods as long as I am credited. Please don't mirror my work unaltered, unless I no longer provide a working download.

User avatar
scrgp9512
Recruit
Recruit
Posts: 5
Joined: Tue Jan 01, 2019 12:05 am

Re: Crashes when opening creature creator

Unread postby scrgp9512 » Tue Jan 01, 2019 8:04 pm

rob55rod wrote:
scrgp9512 wrote:So I'm using Dark Injections for the first time here. I installed it and booted the API launcher and the game launches just fine. However when I go to open the creature creator it never opens, the game crashes and closes before it can do so. I couldn't really find anything here about this already so here's this post. I am using the Steam version and I have GA and C&C with the asymmetry patch.

Hmmm...mind showing me your current DI configuration? (sorry about the confusion above btw)


This was the only thing I changed Image

Everything else is default

Also to the post above, core Spore, C&C, and GA all are validated and the game runs fine without DI installed (it's the only mod I have/had)

User avatar
rob55rod
Tech Support
Tech Support
Sergeant Major of the Davo Army
Sergeant Major of the Davo Army
Posts: 3877
Joined: Sat Jul 02, 2011 9:50 am
Location: Zelem's Nexus, rebuilding.

Re: Crashes when opening creature creator

Unread postby rob55rod » Wed Jan 02, 2019 7:20 pm

scrgp9512 wrote:
rob55rod wrote:
scrgp9512 wrote:So I'm using Dark Injections for the first time here. I installed it and booted the API launcher and the game launches just fine. However when I go to open the creature creator it never opens, the game crashes and closes before it can do so. I couldn't really find anything here about this already so here's this post. I am using the Steam version and I have GA and C&C with the asymmetry patch.

Hmmm...mind showing me your current DI configuration? (sorry about the confusion above btw)


This was the only thing I changed Image

Everything else is default

Also to the post above, core Spore, C&C, and GA all are validated and the game runs fine without DI installed (it's the only mod I have/had)

I think I may know what's going on there. I'll be releasing a bugfix update within the near future. Once that's out, let me know if installing it resolves this issue.
Having trouble with the Spore ModAPI Launcher Kit? Let us know here!

If you're reading this, you have my permission to build off of my mods as long as I am credited. Please don't mirror my work unaltered, unless I no longer provide a working download.

User avatar
scrgp9512
Recruit
Recruit
Posts: 5
Joined: Tue Jan 01, 2019 12:05 am

Re: Crashes when opening creature creator

Unread postby scrgp9512 » Mon Jan 28, 2019 8:27 pm

rob55rod wrote:
scrgp9512 wrote:
rob55rod wrote:Hmmm...mind showing me your current DI configuration? (sorry about the confusion above btw)


This was the only thing I changed Image

Everything else is default

Also to the post above, core Spore, C&C, and GA all are validated and the game runs fine without DI installed (it's the only mod I have/had)

I think I may know what's going on there. I'll be releasing a bugfix update within the near future. Once that's out, let me know if installing it resolves this issue.


I downloaded 2.3.2 and the game still crashes when I try to open the creature editor. Oddly enough I also noticed my game doesn't seem to be detecting my C&C anymore even after a reinstall.

User avatar
rob55rod
Tech Support
Tech Support
Sergeant Major of the Davo Army
Sergeant Major of the Davo Army
Posts: 3877
Joined: Sat Jul 02, 2011 9:50 am
Location: Zelem's Nexus, rebuilding.

Re: Crashes when opening creature creator

Unread postby rob55rod » Mon Jan 28, 2019 9:18 pm

scrgp9512 wrote:I downloaded 2.3.2 and the game still crashes when I try to open the creature editor. Oddly enough I also noticed my game doesn't seem to be detecting my C&C anymore even after a reinstall.

Um...ooookay, that's a first. If you disable all of DI's features in its configurator, does the editor still crash?
Having trouble with the Spore ModAPI Launcher Kit? Let us know here!

If you're reading this, you have my permission to build off of my mods as long as I am credited. Please don't mirror my work unaltered, unless I no longer provide a working download.

User avatar
scrgp9512
Recruit
Recruit
Posts: 5
Joined: Tue Jan 01, 2019 12:05 am

Re: Crashes when opening creature creator

Unread postby scrgp9512 » Fri Feb 01, 2019 8:26 pm

rob55rod wrote:
scrgp9512 wrote:I downloaded 2.3.2 and the game still crashes when I try to open the creature editor. Oddly enough I also noticed my game doesn't seem to be detecting my C&C anymore even after a reinstall.

Um...ooookay, that's a first. If you disable all of DI's features in its configurator, does the editor still crash?


Used Core Spore UI and editor background and disabled all features, still crashes.

User avatar
rob55rod
Tech Support
Tech Support
Sergeant Major of the Davo Army
Sergeant Major of the Davo Army
Posts: 3877
Joined: Sat Jul 02, 2011 9:50 am
Location: Zelem's Nexus, rebuilding.

Re: Crashes when opening creature creator

Unread postby rob55rod » Sat Feb 02, 2019 10:37 am

scrgp9512 wrote:
rob55rod wrote:
scrgp9512 wrote:I downloaded 2.3.2 and the game still crashes when I try to open the creature editor.

Um...ooookay, that's a first. If you disable all of DI's features in its configurator, does the editor still crash?

Used Core Spore UI and editor background and disabled all features, still crashes.

Oooookay...now that's really weird. Um...do you use Discord, Skype, Steam, or anything of the sort, by any chance? Between faster communication and the ability to screenshare if needed (Steam aside), I think that would be a much easier method of diagnosing exactly what's wrong here, if you're open to that...

scrgp9512 wrote:Oddly enough I also noticed my game doesn't seem to be detecting my C&C anymore even after a reinstall.

...and while we're at it, I'd be happy to help you get your Creepy & Cute DLC working again, too.
Having trouble with the Spore ModAPI Launcher Kit? Let us know here!

If you're reading this, you have my permission to build off of my mods as long as I am credited. Please don't mirror my work unaltered, unless I no longer provide a working download.

User avatar
scrgp9512
Recruit
Recruit
Posts: 5
Joined: Tue Jan 01, 2019 12:05 am

Re: Crashes when opening creature creator

Unread postby scrgp9512 » Sat Feb 02, 2019 12:14 pm

rob55rod wrote:
scrgp9512 wrote:
rob55rod wrote:Um...ooookay, that's a first. If you disable all of DI's features in its configurator, does the editor still crash?

Used Core Spore UI and editor background and disabled all features, still crashes.

Oooookay...now that's really weird. Um...do you use Discord, Skype, Steam, or anything of the sort, by any chance? Between faster communication and the ability to screenshare if needed (Steam aside), I think that would be a much easier method of diagnosing exactly what's wrong here, if you're open to that...

scrgp9512 wrote:Oddly enough I also noticed my game doesn't seem to be detecting my C&C anymore even after a reinstall.

...and while we're at it, I'd be happy to help you get your Creepy & Cute DLC working again, too.


Sure I use discord, my tag is Hero of Tulans#3373 but a quick question. Am I supposed to launch the game via the modAPI launcher? When I do that it will crash, but if I launch it regularly through steam the creator opens but the mod isn't there.

User avatar
rob55rod
Tech Support
Tech Support
Sergeant Major of the Davo Army
Sergeant Major of the Davo Army
Posts: 3877
Joined: Sat Jul 02, 2011 9:50 am
Location: Zelem's Nexus, rebuilding.

Re: Crashes when opening creature creator

Unread postby rob55rod » Sun Feb 03, 2019 6:06 am

Mystery solved. Moral of the story: Don't install more than one version of the game at once.
Having trouble with the Spore ModAPI Launcher Kit? Let us know here!

If you're reading this, you have my permission to build off of my mods as long as I am credited. Please don't mirror my work unaltered, unless I no longer provide a working download.


Return to “Fixed Bugs”